Как обновить Eclipse, ADT-плагин и Android SDK

Обсуждение материалов из раздела Памятка
Ответить
Аватара пользователя
damager82
Администратор
Сообщения: 1383
Зарегистрирован: 07 янв 2012, 11:32
Контактная информация:

Как обновить Eclipse, ADT-плагин и Android SDK

Сообщение damager82 » 06 ноя 2011, 03:00

Мне понадобилось установить Google APIs от Google, чтобы в AVD появились стандартные гугл приложения – Google Maps, Navigation и прочее. В моей текущей версии ADT я не смог это сделать. SDK Manager не видел на сайте того, что мне было нужно, показывал «no packages found» в ветке google inc.

Click here to read this article!
Последний раз редактировалось damager82 06 ноя 2011, 07:00, всего редактировалось 1 раз.
Добро пожаловать на форум сайта StartAndroid
ИзображениеИзображение

tyapavel
Сообщения: 11
Зарегистрирован: 09 янв 2012, 01:31

Re: Как обновить Eclipse, ADT-плагин и Android SDK

Сообщение tyapavel » 10 янв 2012, 15:58

Я установил Motodevstudio от Motorolla. Довольно неплохо работает в Линукс. Есть набор сниппетов, неплохой редактор локализаций, на их сайте есть видеоролик по нему, правда на английском, но всё понятно. Можно скачать дополнение к Eclipse. Можно и всю студию вместе сEclipse.

=bor=
Сообщения: 267
Зарегистрирован: 21 мар 2013, 12:26

Re: Как обновить Eclipse, ADT-плагин и Android SDK

Сообщение =bor= » 25 мар 2013, 10:41

damager82 писал(а):Мне понадобилось установить Google APIs от Google, чтобы в AVD появились стандартные гугл приложения – Google Maps, Navigation и прочее. В моей текущей версии ADT я не смог это сделать. SDK Manager не видел на сайте того, что мне было нужно, показывал «no packages found» в ветке google inc.

Click here to read this article!
Всё обновилось, кроме одного.
Получаю вот такое сообщение:
Unable to read repository at https://download.eclipse.org/eclipse/up ... ontent.xml.
Unrecognized SSL message, plaintext connection?
Что бы это могло быть? :(

=bor=
Сообщения: 267
Зарегистрирован: 21 мар 2013, 12:26

Re: Как обновить Eclipse, ADT-плагин и Android SDK

Сообщение =bor= » 28 апр 2013, 09:50

Что-то никто не ответил. :(
Пытаюсь обновить Eclipse, жму на Help/Check for updates, и в итоге получаю следующее сообщение:
Some sites could not be found. See the error log for more detail.
No repository found at http://download.eclipse.org/birt/update-site/3.7.
No repository found at https://download.eclipse.org/eclipse/updates/3.7.
No repository found at http://download.eclipse.org/eclipse/updates/3.7.
No repository found at http://download.eclipse.org/releases/indigo.
No repository found at https://dl-ssl.google.com/android/eclipse.
Кто-нибудь может подсказать, в чём проблема?

Аватара пользователя
damager82
Администратор
Сообщения: 1383
Зарегистрирован: 07 янв 2012, 11:32
Контактная информация:

Re: Как обновить Eclipse, ADT-плагин и Android SDK

Сообщение damager82 » 29 апр 2013, 11:07

Если "Unrecognized SSL message, plaintext connection", то попробуйте иcпользовать http, вместо https
Добро пожаловать на форум сайта StartAndroid
ИзображениеИзображение

=bor=
Сообщения: 267
Зарегистрирован: 21 мар 2013, 12:26

Re: Как обновить Eclipse, ADT-плагин и Android SDK

Сообщение =bor= » 29 апр 2013, 20:33

damager82 писал(а):попробуйте иcпользовать http, вместо https
Вот оно что. Спасибо, попробую.

=bor=
Сообщения: 267
Зарегистрирован: 21 мар 2013, 12:26

Re: Как обновить Eclipse, ADT-плагин и Android SDK

Сообщение =bor= » 24 июн 2013, 14:09

При попытке обновить Эклипс в SDK получаю такое:
Fetching https://dl-ssl.google.com/android/repos ... list-2.xml
Fetched Add-ons List successfully
Fetching URL: https://dl-ssl.google.com/android/repos ... tory-8.xml
Done loading packages.
Fetching https://dl-ssl.google.com/android/repos ... list-2.xml
Failed to fetch URL https://dl-ssl.google.com/android/repos ... list-2.xml, reason: Unknown Host dl-ssl.google.com
Fetched Add-ons List successfully
Fetching URL: https://dl-ssl.google.com/android/repos ... tory-8.xml
Failed to fetch URL https://dl-ssl.google.com/android/repos ... tory-8.xml, reason: IO Unknown Host dl-ssl.google.com
Done loading packages.
Может, эти ссылки ваще нерабочие?
Поделитесь рабочими ссылками, плиз.

DamirFelix
Сообщения: 3
Зарегистрирован: 17 сен 2013, 13:44

Re: Как обновить Eclipse, ADT-плагин и Android SDK

Сообщение DamirFelix » 17 сен 2013, 13:55

у меня проблема, после обновления (17.09.2013) Android SDK Tools до версии 22.2 не могу создать новый проект, выдает ошибку:

хотя Android Support Library установлен и до обновления всё нормально было, проверил Eclipse на наличие обновлений, они не нужны
Вложения
Снимок.JPG
Снимок.JPG (50.12 КБ) 9523 просмотра

Артур
Сообщения: 2
Зарегистрирован: 08 окт 2013, 15:36

Re: Как обновить Eclipse, ADT-плагин и Android SDK

Сообщение Артур » 08 окт 2013, 15:46

Источник: http://androiddev.orkitra.com/?p=86289

1. Заходим Help > Install New Software.
2. В Work with, пишем:
3. https://dl-ssl.google.com/android/eclipse/
4. Выбираем Developer Tools / Android Development Tools.
5. Жмём Next

Мне помогло.

Ответить