Google Android - это несложно

Добро пожаловать на форум сайта startandroid.ru
Текущее время: 20 июл 2018, 03:37

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ 1 сообщение ] 
Автор Сообщение
 Заголовок сообщения: FirebaseUI
СообщениеДобавлено: 20 апр 2018, 12:13 

Зарегистрирован: 20 апр 2018, 11:59
Сообщений: 1
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Добрый день.
Собираю проект по туториалам, делаю все как написано но столкнулся с проблемой разрешения зависимостей.
При добавлении строчки в build.grandle(app):
implementation 'com.firebaseui:firebase-ui-auth:3.2.2'
отваливаются в ошибку:
implementation 'com.android.support:appcompat-v7:27.1.1'
implementation 'com.google.firebase:firebase-auth:15.0.0'

Перерыл поиск, но к сожалению не нашел нужного решения.
Подскажите как исправить конфликт библиотек.
--------------------------------------------------------------------------------------------

Не получил помощь на форуме... зато нашел сам решение...
https://github.com/firebase/FirebaseUI-Android
Делаем по этому принципу зависимости и все ОК:
implementation "com.google.firebase:firebase-auth:$FOO"
implementation "com.google.android.gms:play-services-auth:$FOO"

implementation "com.android.support:design:$BAR"
implementation "com.android.support:customtabs:$BAR"
implementation "com.android.support:cardview-v7:$BAR"


В моем случае $FOO = 15.0.0 $BAR = 27.1.1


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ 1 сообщение ] 

Часовой пояс: UTC + 3 часа


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Powered by phpBB® Forum Software © phpBB Group
Русская поддержка phpBB